Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Damian Green 452 posts 1433 karma points
    Mar 21, 2014 @ 17:17
    Damian Green
    0

    Bug - Get a RTE when i click the toolbar icon

    I selected a document type and clicked the Census toolbar button and got this RTE in the popup:

    [NullReferenceException: Object reference not set to an instance of an object.]
       umbraco.cms.businesslogic.web.Document.get_Text() +6
       Census.UmbracoObject.Content.GetFriendlyPathForDocument(Document document) +306
       Census.UmbracoObject.Content.ToDataTable(Object usages) +390
       Census.UmbracoObjectRelations.DocumentTypeToContent.GetRelations(Object id) +368
       Census.Web.Usages.Page_Load(Object sender, EventArgs e) +399
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +24
       System.Web.UI.Control.LoadRecursive() +70
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3063

    It works ok for other doc types though.

     

  • Tom Fulton 2030 posts 4984 karma points c-trib
    Apr 30, 2014 @ 04:55
    Tom Fulton
    0

    Hi Damian,

    Apologies for the delay. I was able to reproduce the error when the related content was in the Recycle Bin. Not sure if that's the same case as you, but likely as it was the exact same error. If you're still using this, feel free to give v1.0.2 a shot which has a fix for that case.

    Thanks! Tom

Please Sign in or register to post replies

Write your reply to:

Draft