Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simon Eldevig 29 posts 190 karma points
    Dec 13, 2019 @ 09:39
    Simon Eldevig
    0

    Redirect Manager doesn't work in Umbraco 8.1.3

    We are using SEO Checker 2.8.2 in a Umbraco 8.1.3 solution and the redirect manager doesn't seem to work. Nothing simply happens when we click the Save button and I've added a screenshot of the error in the console.enter image description here

    enter image description here Best Regards

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Dec 13, 2019 @ 09:42
    Richard Soeteman
    0

    Hi SImon, Clear Angular /client dependency cache please.

    Best,

    Richard

  • Simon Eldevig 29 posts 190 karma points
    Dec 13, 2019 @ 09:43
    Simon Eldevig
    0

    Hi Richard,

    No we do not. Don't know if you saw my edit, we seem to get an error in the console now.

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Dec 13, 2019 @ 09:45
    Richard Soeteman
    0

    Hi Simon

    I've edited as well ;-) Try that and redirect to node doe swork?

    Best,

    Richard

  • Simon Eldevig 29 posts 190 karma points
    Dec 13, 2019 @ 09:45
    Simon Eldevig
    0

    Just updated the Client Dependency which didn't fix the issue.

    It seems that I can create redirects when I use the node picker, but the string input doesn't work.

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Dec 13, 2019 @ 09:49
    Richard Soeteman
    100

    I think I fixed that issue already

    Just did a check and works here. Can you try this hotfix version?

    Best,

    Richard

  • Simon Eldevig 29 posts 190 karma points
    Dec 13, 2019 @ 09:55
    Simon Eldevig
    0

    Hi again Richard,

    Just tried to install it and it still doesn't work. I can see that it actually makes a successful to the save endpoint, but i doesn't close the sidebar and the redirect doesn't seem to get saved.

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Dec 13, 2019 @ 09:58
    Richard Soeteman
    0

    That must be Clientdepenendcy framwork. Anything in the Umbarco log files as well? Just did a test with this exact version and your redirects..

  • Simon Eldevig 29 posts 190 karma points
    Dec 13, 2019 @ 10:03
    Simon Eldevig
    0

    Just updated Client Dependency and now it works. Is it possible to create a redirect to a page with a querystring? I get this validation message, so I guess it's because it just compares the path and not the whole string? enter image description here When will the version 2.9.0 be in Nuget? :-)

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Dec 13, 2019 @ 10:25
    Richard Soeteman
    0

    Yes possible when you set that in general settings.

    Nuget will be out either next week or early next year.

  • Simon Eldevig 29 posts 190 karma points
    Dec 13, 2019 @ 10:37
    Simon Eldevig
    0

    Great - thanks for the help!

Please Sign in or register to post replies

Write your reply to:

Draft