Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jan Skovgaard 11245 posts 23441 karma points MVP 6x admin c-trib
    Apr 02, 2014 @ 13:58
    Jan Skovgaard
    0

    User rights to access SEO checker 1.5.1

    Hi Richard

    I'm currently having a weird issue using SEO checker 1.5.1. If I try to access the SEO checker section with another user than the default admin user the trees won't load. I just see the spinner.

    I don't get anything in the tracelog - not sure if SEO checker is hooking into it or using some other logging?

    However in my browsers console log I get this error

    Uncaught TypeError: Cannot read property 'data' of null

    Do you have any idea what is going on?

    Cheers, Jan

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Apr 02, 2014 @ 14:30
    Richard Soeteman
    0

    Hi Jan,

    That is weird. I will have a look what is the user type and what is the Umbraco version?

    Thanks,

    Richard

  • Jan Skovgaard 11245 posts 23441 karma points MVP 6x admin c-trib
    Apr 02, 2014 @ 15:43
    Jan Skovgaard
    0

    Hi Richard

    Well of course - Funny how I forget to mention these details as it's usually the first thing I ask others about ;-)

    The Umbraco version is 4.11.10 and we have defined a user type called "Webmaster". But I also noticed it happened to users even though I gave them the administrator role.

    Cheers, Jan

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Apr 02, 2014 @ 15:48
    Richard Soeteman
    0

    Hi Jan,

    One more question can you give the webmaster admin rights AND access to settings node does that "solve" the issue?

    Thanks,

    Richard

  • Jan Skovgaard 11245 posts 23441 karma points MVP 6x admin c-trib
    Apr 02, 2014 @ 15:50
    Jan Skovgaard
    0

    Hi Richard

    I just double checked. If I give the Webmaster the administrator type (admin rights) I see the same issue.

    /Jan

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Apr 02, 2014 @ 15:53
    Richard Soeteman
    0

    Hi Jan, Also with settings access explicit enabled? Thanks,

    Richard

  • Jan Skovgaard 11245 posts 23441 karma points MVP 6x admin c-trib
    Apr 02, 2014 @ 15:57
    Jan Skovgaard
    0

    Hi Richard

    Not sure what you mean by that? :)

    /Jan

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Apr 02, 2014 @ 16:04
    Richard Soeteman
    0

    Picture how to specify the settings helps maybe? It's not the solution but want to make sure you have the exact problem as my other customer is having.

    enter image description here

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Apr 02, 2014 @ 16:06
    Richard Soeteman
    0

    Picture how to specify the settings helps maybe? It's not the solution but want to make sure you have the exact problem as my other customer is having.

    enter image description here

  • Jan Skovgaard 11245 posts 23441 karma points MVP 6x admin c-trib
    Apr 02, 2014 @ 16:09
    Jan Skovgaard
    0

    Hi Richard

    Thanks for the image - Now I get it :)

    Actually it was enough for me to simply give the webmaster user of the type webmaster access to the settings section. Then I could access SEO checker.

    So seems that if the user can't access settings it's failing.

    Cheers, Jan

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Apr 02, 2014 @ 16:13
    Richard Soeteman
    1

    Thanks for checking Jan. I've scheduled a debug session for tomorrow. Sorry for the hassle now.

    Cheers,

    Richard

  • Jan Skovgaard 11245 posts 23441 karma points MVP 6x admin c-trib
    Apr 02, 2014 @ 16:16
    Jan Skovgaard
    0

    No need to be sorry Richard, just happy that we have figured out what it is - Now I can tell this to our client and then we will take it from there :)

    Thanks for the help - will you post in here when there is a fix ready?

    Cheers, Jan

  • Richard Soeteman 3722 posts 11521 karma points MVP
    Apr 02, 2014 @ 16:19
    Richard Soeteman
    0

    Yes I will post the fix here.

Please Sign in or register to post replies

Write your reply to:

Draft