Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Matt Taylor 813 posts 1903 karma points
    Jan 15, 2015 @ 17:18
    Matt Taylor
    0

    Error viewing Sitemap - Value cannot be null. Parameter name: umbracoContext

    I'm running a licensed version of SEO Checker v1.6.1.

    I've been setting things up in the config section and I tried previewing the Sitemap.xml file but ended up with the following YSOD.

    Server Error in '/' Application.

    Value cannot be null.
    Parameter name: umbracoContext

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentNullException: Value cannot be null.
    Parameter name: umbracoContext

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace:

    [ArgumentNullException: Value cannot be null.
    Parameter name: umbracoContext]
       Umbraco.Web.UmbracoHelper..ctor(UmbracoContext umbracoContext) +214
       umbraco.library.IsProtected(Int32 DocumentId, String Path) +43
       SEOChecker.Handlers.HttpHandlers.XmlSitemapHandler.(HttpContext , List`1 , Int32 ) +159
       SEOChecker.Handlers.HttpHandlers.XmlSitemapHandler.RenderXmlSiteMap(HttpContext context) +305
       SEOChecker.Handlers.HttpHandlers.XmlSitemapHandler.ProcessRequest(HttpContext context) +150
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +913
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165
    



    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18447

     

    As far as I know I've set it all up in the same way as another site with the same versions and that one is working fine.

    I'm looking forward to putting the site live soon so any help would be appreciated. :-)

    Regards,

    Matt

  • Jan Skovgaard 11242 posts 23414 karma points MVP 6x admin c-trib
    Jan 15, 2015 @ 20:16
    Jan Skovgaard
    0

    Hi Matt

    Did you just install the package? Have you checked that /config/Applications.config and /config/trees.config files don't miss anything? Has the SEO checker section been added in applications.config for instance?

    /Jan

  • Matt Taylor 813 posts 1903 karma points
    Jan 15, 2015 @ 22:19
    Matt Taylor
    102

    Hi Jan,

    The package was installed a long time ago. This is the second of project that was based on the Hybrid Framework from Jeroen.

    And it may even be a copy of the first one which is working fine. The only difference is that the second project has been upgraded to a later version of Umbraco.

    Well I installed v1.8.1 of the SEO Package and that has fixed the issue.

    Regards,

    Matt

  • Jan Skovgaard 11242 posts 23414 karma points MVP 6x admin c-trib
    Jan 16, 2015 @ 07:23
    Jan Skovgaard
    0

    Hi Matt

    Ok, glad you found a solution at least and thanks for sharing :)

    /Jan

  • Richard Soeteman 3642 posts 11097 karma points MVP
    Jan 16, 2015 @ 08:23
    Richard Soeteman
    1

    Thanks Jan and indeed the umbracoContext is no longer available for Sitemap and Robots files in the later versions of Umbraco. Was already fixed and I will contact the developers of the Hybrid Framework if they can update the package.

    Thanks,

    Richard

  • Matt Taylor 813 posts 1903 karma points
    Jan 16, 2015 @ 12:18
    Matt Taylor
    0

    Hi Richard,

    The versions of SEO Checker, Umbraco and the Hybrid Framework are all compatible when you download the Framework.

    I like to upgrade my Hybrid Framework projects to the latest Umbraco release so that where the problem lies. But yes I'm sure upgrading the version of SEO in it will prevent other people experiencing the same problem.

    Regards,

    Matt

  • Arjun Singh 8 posts 78 karma points
    Mar 07, 2018 @ 06:48
    Arjun Singh
    0

    Hi Matt/ all,

    i am getting the same error in below method call, can any one please suggest.

    var homePageNode = new Uri(umbraco.library.NiceUrl(partner.Id));
    

    UmbracoContext is null, thanks in advance.

  • Matt Taylor 813 posts 1903 karma points
    Mar 07, 2018 @ 12:21
    Matt Taylor
    0

    My solution above was to upgrade the SEO package.

    Well I installed v1.8.1 of the SEO Package and that has fixed the issue.

Please Sign in or register to post replies

Write your reply to:

Draft