Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • George 7 posts 87 karma points
    Aug 30, 2019 @ 11:42
    George
    0

    Seo Checker Specific Redirects are not working

    I am using seo checker version 1.10.3

    There are some of the redirect links that are giving me 404 error page ,could anyone please help me what to do?

    If I add or remove one letter the redirect works perfectly fine ,but I have problems working with the link I want.

  • George 7 posts 87 karma points
    Aug 30, 2019 @ 13:31
    George
    0

    I even checked the database ,everything is looking good in there ,I am not sure why some url's get buggy ,is this fixable?

  • Richard Soeteman 3625 posts 11059 karma points MVP
    Sep 02, 2019 @ 05:33
    Richard Soeteman
    0

    The url is propaly logged as 404 as well remove from inbound link errors please then restart the site and it will propably work. This is fixed in later versions of SEOChecker.

    Best,

    Richard

  • George 7 posts 87 karma points
    Sep 04, 2019 @ 13:17
    George
    0

    I have upgraded SEOChecker on my test site but I get this strange error ,could you please help with this? enter image description here

  • Richard Soeteman 3625 posts 11059 karma points MVP
    Sep 04, 2019 @ 15:24
    Richard Soeteman
    0

    Did you upgrade to v2.8? That version is Umbraco V8 specific, best to upgrade to 2.2.x for V7.

    Best,

    Richard

  • George 7 posts 87 karma points
    Sep 05, 2019 @ 06:49
    George
    0

    Hi Richard ,

    My upgrade was on 2.2.4 ,currently running Umbraco 7.6.13 , this umbraco was upgraded from older one couple of months ago ,I am going to run reindexing today and see where it gets me ,hopefully this works.

  • George 7 posts 87 karma points
    Sep 05, 2019 @ 07:57
    George
    0

    Reindexing did not help unfortunately.

    Can this be Trees.config problem?

    These are the two options I have used ,I took it from the manual -

    <add initialize="true" sortOrder="0" alias="seochecker" application="seochecker"
    title="SEO Checker" iconClosed="icon-folder" iconOpen="icon-folder-open"
    type="SEOChecker.Trees.SEOCheckerTreeController, SEOChecker" />
    

    and the other one that I had in the old version was

    <add initialize="true" sortOrder="10" alias="seochecker" application="seochecker" title="Seo Checker" iconClosed="folder.gif" iconOpen="folder_o.gif" type="SEOChecker.Trees.SEOCheckerTree,SEOChecker" /> 
       <add initialize="true" sortOrder="20" alias="seocheckerValidationQueue" application="seochecker" title="Seo Checker" iconClosed="folder.gif" iconOpen="folder_o.gif" type="SEOChecker.Trees.ValidationQueueTree,SEOChecker" /> 
       <add initialize="true" sortOrder="30" alias="seocheckerRedirectManager" application="seochecker" title="Seo Checker" iconClosed="folder.gif" iconOpen="folder_o.gif" type="SEOChecker.Trees.RedirectManagerTree,SEOChecker" /> 
       <add initialize="true" sortOrder="40" alias="seocheckerIssues" application="seochecker" title="Seo Checker" iconClosed="folder.gif" iconOpen="folder_o.gif" type="SEOChecker.Trees.IssuesTree,SEOChecker" /> 
       <add initialize="true" sortOrder="50" alias="seocheckerSettings" application="seochecker" title="Seo Checker" iconClosed="folder.gif" iconOpen="folder_o.gif" type="SEOChecker.Trees.SettingsTree,SEOChecker" />
    

    Hope this can be helpful.

  • Richard Soeteman 3625 posts 11059 karma points MVP
    Sep 05, 2019 @ 15:23
    Richard Soeteman
    1

    7.6 doesn't contain the V2 Methods of SEOChecker are using. V2 expects at least 7.9 from the top of my head. V1.x works but might be better top upgrade Umbraco?

    Best,

    Richard

  • George 7 posts 87 karma points
    Sep 06, 2019 @ 06:38
    George
    0

    Richard ,

    Thank you for your response.

    I am not sure if umbraco update is what my clients are looking for. We have quite large database (20-30 gigs) and umbraco update always came with some issues based from previous experiences.

    One last question for this thread please.

    if I install SEOChecker V1.x (the latest first version) will there be the url redirect fix that I'm looking for? or do I need SEOChecker V2?

    Thank you ,

    Best regards ,

    George

  • Richard Soeteman 3625 posts 11059 karma points MVP
    Sep 09, 2019 @ 05:35
    Richard Soeteman
    100

    V2 contains the fix indeed. But if you keep your inbound 404 logs clean you should not have the issue as well.

    Best,

    Richard

  • George 7 posts 87 karma points
    Sep 09, 2019 @ 08:15
    George
    0

    Thank you ,

    I will try cleaning inbound 404 logs ,hopefully this solves my problem for now.

Please Sign in or register to post replies

Write your reply to:

Draft