Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Miguel S. 30 posts 87 karma points
    Nov 12, 2012 @ 23:05
    Miguel S.
    0

    Install is not working

    I started with a brand new clean umbraco 4.10 install, no started packages. 

    I installed the newest TeaCommerce package, it said the install was successful but almost nothing is there. 

    The TeaCommerce icon does not show up. A couple XSLT tempaltes get populated (email ones)

    Also, none of the following: 

     

    • Macros
    • Doc Types
    • Templates
    • Content Nodes
    • The normal XSLT files
    I have installed the previous version with no problems on other umbraco sites. Not sure why this one isn't working. 
    This error is in the log 
    System.NullReferenceException: Object reference not set to an instance of an object. at umbraco.cms.businesslogic.packager.data.Save(PackageInstance package, String dataSource)
    My permissions are pretty normal, I can't see that being an issue

     

  • Rune Grønkjær 1341 posts 3031 karma points
    Nov 13, 2012 @ 08:21
    Rune Grønkjær
    0

    Hi Miquel,

    We just released v1.4.4.0, which should be compatible with Umbraco 4.10. If that's the version you are using we would really like to know, so we can find and fix the problem.

    /Rune

  • Miguel S. 30 posts 87 karma points
    Nov 13, 2012 @ 09:30
    Miguel S.
    0

    As my post states, it is a clean install of Umbraco 4.10

    I tried installing TeaCommerce from a local package zip and also from the repository. Same result as specified above. 

  • Rune Grønkjær 1341 posts 3031 karma points
    Nov 13, 2012 @ 09:38
    Rune Grønkjær
    0

    Tea Commerce does not install any Macros, Doc types and such. It places two xslt's in the xslt folder and thats it. If the custom section have not apeared, maybe your user does not have the proper rights set for it. Try looking at you user settings for that one. Also you might need to reload the admin page (F5) for the Tea Commerce icon to show.

    If you want Macros, Doc types and such you can install the Tea Commerce starter kit and copy what you need from there. We are working on a brand new starter kit, but it will first be ready when we launch Tea Commerce 2.0

    /Rune

  • Miguel S. 30 posts 87 karma points
    Nov 13, 2012 @ 09:46
    Miguel S.
    0

    That explains the missing macros and such. 

    However, the custom section did not appear. 

    Which User are you referring to? Either way I think I'm covered. I'm logged in as the Umbraco Admin and the IIS user has full permissions to the whole folder. 

  • Miguel S. 30 posts 87 karma points
    Nov 13, 2012 @ 09:46
    Miguel S.
    0

    Forgot to say, yes I refreshed and cleared my cache etc

  • Rune Grønkjær 1341 posts 3031 karma points
    Nov 13, 2012 @ 09:50
    Rune Grønkjær
    0

    Cool. What I meant was the umbraco backend user (Admin). See if that has the correct permissions and maybe check if the Tea Commerce section is there at all. Like the screenshot below. What version of Tea Commerce did you install? You can check that under developer installed packages.

    /Rune

  • Miguel S. 30 posts 87 karma points
    Nov 13, 2012 @ 09:54
    Miguel S.
    0

    Ohh my... that did the trick. That could have saved me A LOT of time if I caught that one. 

    Thanks for the help Rune.

    Btw, when do you guys expect to have the new starter kit out? 

    Thanks,

    Miguel

  • Rune Grønkjær 1341 posts 3031 karma points
    Nov 13, 2012 @ 09:57
    Rune Grønkjær
    0

    Well I hope we can have it ready this year when we launch Tea Commerce 2.0. But we are spending a lot of time on first getting Tea Commerce 2.0 ready for launch, so it might first come out in the start of 2013.

    /Rune

  • Hasheem Maloo 7 posts 29 karma points
    Nov 20, 2012 @ 23:26
    Hasheem Maloo
    0

    That caught me out too! ... Miguel what a small world.. its been ages man, nice to see that you're working with tea commerce too! 

     

Please Sign in or register to post replies

Write your reply to:

Draft